Już jakiś czas temu zrobił się modny temat wykorzystania Jupyter Notebooks, które to rozwiązanie pozwala na dodawanie działającego na żywo kodu aplikacji do wyświetlanej właśnie dokumentacji. Co więcej wynik działania kodu od razu jest widoczny w dokumentacji – tak jak poniżej: Warto wspomnieć, iż Notebooki mogą również wyświetlać grafikę i dlatego właśnie osoby przygotowujący modele AI tak bardzo pokochały Jupyter notebooks: O ile dla Python, F# i języka R Jupyter Notebook’i były dostępne od dawna, o tyle zupełnie niezauważenie przeszła informacja, iż funkcjonalność dostępna jest dla PowerShell no i od dłuższego czasu dla .NET. Możemy to poćwiczyć używając linku: https://mybinder.org/v2/gh/dotnet/interactive/master?urlpath=lab Warto wspomnieć, że od dłuższego czasu do dyspozycji mamy Azure Notebooks Preview – czekam, aż zostanie zintegrowane z CloudShell i pięknie będzie można publikować ćwiczenia i konfiguracje do Azure. A tutaj można zobaczyć, jak to działa – tylko proszę się zalogować używając swojego konta organizacji, aby móc wykonać kod poprzez wciśnięcie Shift i Enter: https://azurenotebooks-mariuszferdyn.notebooks.azure.com/j/lab/tree/KolejnaLiczba.ipynb A tak na marginesie dzieci od dawna uczyły się Pythona używając bardzo fajnego rozwiązania rodem z Runestone Interactive, a mianowicie: http://python.oeiizk.edu.pl/ematerialy/python_obliczenia/0_piaskownica.html# Jupyter Notebooks became popular that allows us to add live application code to the documentation being displayed. What’s more, the result of the running … PowerShell and .Net for Jupyter Notebooks – Azure Notebooks what’s is the future?Read more
Month: April 2020
How to create Azure Monitor Alerts based on policy definitions?
First of all, you need to have Log Analytics Workspace with logs from Activity log: More info: https://docs.microsoft.com/en-us/azure/azure-monitor/platform/activity-log-collect Please go to Monitor. Go to Tab Alerts (You can go to directly to this link: https://portal.azure.com/#blade/Microsoft_Azure_Monitoring/AzureMonitoringBrowseBlade/alertsV2) Press New alert rule Press Resource Select subscription and Log Analytics that have like here: To use custom queries, you should be able to see here something like this: Choose: Select Type a query e.g.: AzureActivity| where TimeGenerated > ago(60d) and OperationNameValue starts with “Microsoft.Authorization/roleDefinitions/write” Configure e.g. Number of results greater than 0. Period and Frequency. Create action groups – who should receive alerts. Specify Subject line and Alert rule name Save Alert References 1: https://docs.microsoft.com/en-us/azure/azure-monitor/platform/activity-log-collect References 2: https://docs.microsoft.com/en-us/azure/azure-monitor/platform/alerts-log
DevExpress – Error: Unable to get property ‘validator’ of undefined or null reference
In case of Error: Error: Unable to get property ‘validator’ of undefined or null reference Add to web.config (at the end in <devExpress> section): <resources> <add type=“ThirdParty“ /> <add type=“DevExtreme“ /> </resources> Like here:
DevExpress – Incorrect route to ASPxUploadProgressHandlerPage.ashx
In case of error: System.Exception Incorrect route to ASPxUploadProgressHandlerPage.ashx. Please use the IgnoreRoute method to ignore this handler’s route when processing requests. Please edit file RouteConfig.cs adding: routes.IgnoreRoute(“{resource}.aspx/{*pathInfo}”); routes.IgnoreRoute(“{resource}.asmx/{*pathInfo}”); routes.IgnoreRoute(“{resource}.ashx/{*pathInfo}”); Like this: Please do not forget add to Layout file: @Html.DevExpress().GetStyleSheets( new StyleSheet { ExtensionSuite = ExtensionSuite.NavigationAndLayout }, new StyleSheet { ExtensionSuite = ExtensionSuite.Editors } ) @Html.DevExpress().GetScripts( new Script { ExtensionSuite = ExtensionSuite.NavigationAndLayout }, new Script { ExtensionSuite = ExtensionSuite.Editors } ) Like this:
Linux Azure Files mount problem
In the case of: mount error(13): Permission denied or mount error(16): Device or resource busy probably your kernel doesn’t support encryption CIFS, so please Disable “Secure transfer required” And use this command: sudo mount -t cifs //STORAGEACCOUNTNAME.file.core.windows.net/SHARENAME /mnt -o vers=2.1,username=YOUR_PASSWORD_ENDING==,dir_mode=0777,file_mode=0777,sec=ntlmssp An unencrypted transfer is working only in the same region where is your VM. If you receive something like this: mount: wrong fs type, bad option, bad superblock on you need to install cifs: sudo apt install cifs-utils Troubleshooter: https://gallery.technet.microsoft.com/Troubleshooting-tool-for-02184089